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1Introduction 
Welcome to the ICEM to AliasStudio Transition Guide.  Designed for technical surfacing 
professionals, this guide focuses on the key tools and techniques required to build Class A 
surfaces.

Before you read this guide, we recommend that you read the Getting Started guide.  This 
will give you the fundamental tools for viewing and zooming, using the menus and palettes, 
and picking and moving objects.

It will also show you how to install and use the on-line help, which gives you access to all 
the reference manuals and tutorials.

Reference Card

Ideally you will have access to AliasStudio while 
reading this guide, and be able to practice and 
learn the workfl ows presented.  To help you, a 
Reference Card is provided at the rear of this guide 
for you to pull out and use to help remember the 
keyboard and mouse combinations described.

Further Tutorials

After you read this guide, you may want  to look at 
the Technical Surfacing tutorial provided as HTML 
and as a PDF in the on-line help.  This has detailed 
examples of how the tools are used in typical 
modeling scenarios.

If you are interested in using AliasStudio for 
rendering and animation, or as a general CAD system, 
you can select the relevant tutorials in the Learning AliasStudio guide.

The guide starts with some hints and tips on using and simplifying  the AliasStudio 
interface.

you can select the relevant tutorials in the Learning AliasStudio guide.
rendering and animation, or as a general CAD system, 
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Read the Prompt Line...

Many people prefer to learn by experimenting, rather than reading reference manuals.  The 
AliasStudio tools are well designed, and often you will be able to use them just by trying 
them out.  The key is to always read the Prompt Line, where a tool will guide you through 
the steps and selections you need to make.

Unlike ICEM, the Prompt Line is at the top of the AliasStudio screen.  This location cannot 
be modifi ed or customized.

To view previous prompt messages, you can open the Prompt Line History by clicking on 
the text symbol to the left of the prompt line.  This can help you understand why a tool has 
failed, or to review the input sequence required for a tool.

The prompt line always requests the type of input a tool needs, for example a curve, or a 
vector.  This is used instead of the selection window workfl ow in ICEM.

Option Windows

In ICEM, option windows appear automatically when a 
tool is selected, and stay on screen as long as the tool 
is being used.

In AliasStudio you need to specifi cally open the option 
window by either double-clicking on an icon, or 
moving the mouse to the square symbol (❑) on a menu.  

A short-cut for both is to hold the Shift key down when 
selecting the tool.

Some tools have a simple and an advanced tab; use 
the advanced tab to access all the available options.

Using the interface
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Palette & Shelf

The Palette contains all the modeling tools and is designed as the standard user interface 
that you will see on any installation of AliasStudio.

The Shelf is designed to be customized by each individual user to suit their preferred way 
of working.  Tools from the Palette can be dragged onto the shelf and arranged in tabs.  
Experienced users will build up their own customized Shelf over many months, and 
eventually it may replace the Palette altogether in their workfl ow.

The Shelf that appears when you fi rst open AliasStudio is intended only as an example of 
how you may customize the tools.  There is a danger that you waste time learning the 
location of tools on the Palette and the Shelf!  So, we recommend that you close the shelf 
when you start to learn the software, and later create your own shelf to suit your preferred 
workfl ow.

...the default Shelf has duplicates of the Palette tools – don’t try to learn the Shelf tools

Choose the Palette Position

Initially the Palette is positioned on the left of the screen, 
fl oating above the workspace.

To locate the Palette tools at the bottom of the screen 
(similar to the Geometry Block location in ICEMsurf), use 
Preferences > Interface  >Palette/Shelves Layout ❑ and 
set your preference in the option window. 

Marking Menus

The marking menus have duplicates of common tools, such as Pick, Move and Rotate. 
Using the Marking Menus is optional – many new users choose to ignore them initially, in 
order to reduce the complexity of the interface.  Most experienced users will create their 
own, customized marking menus and use them to speed up their workfl ow, particularly for  
selecting and moving control points to sculpt surfaces.

See pages 36-38 in the Getting Started guide for more information on customizing the 
interface.

Customizing the interface
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Instead of a Special View Block on the right side of the 
ICEM screen, AliasStudio has the Viewing Panel, which 
appears in the top left corner of the perspective window 

View Planes & Work Planes

AliasStudio doesn’t use the concept of a separate work 
plane and view plane.  

In a 3D view, only the XY (ground) plane is shown as a grid.  Objects can be placed on this 
ground plane using grid snap.  Otherwise, objects are positioned by snapping them to 
points on existing geometry, and motion is controlled in the x,y and z directions using the 
mouse buttons.

This changes when you switch to a 2D orthographic view (with no 
perspective).  You can freely place objects and they are drawn on the 
plane of the view (similar to setting the work plane the same as the 
view plane in ICEM).  The mouse buttons also switch to a drawing 
board mode  (free / horiz / vert) which allows for quick and accurate 
control of geometry.

Construction Planes 
(Workplanes)

To work in an alternative to the default x,y,z plane, use 
Construction > Plane to create a new work plane.  You can 
have as many planes as you like, but you can only set one at a 
time to be the Construction Plane.

Note: The Preferences > General 
Preferences Input options control how 
the mouse buttons work in a 
construction plane.

Views & Work planes
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Constrained Tumble

The Azimuth/Elevation and Twist 
icons give you extra control over the 
tumbling of the view.  

Alternatively you can customize the 
view interaction in the General 
Preferences option window, Input 
section. 

Selecting Azimuth/Twist changes the 
action of the right mouse button. 
Moving the mouse vertically zooms in 
and out, moving the mouse horizontally 
twists. Experiment with the two options 
to see which feels more familiar.

Compressed View

When Perspective is 
turned off, the Aspect 
Ratio icon is shown. 
Click on the icon, and 
then click and drag the 
mouse to interactively 
compress the view.

To return the view to 
equal scaling, a 
shortcut is to turn 
perspective on, and 
then off again in the 
Viewing Panel.  

Alternatively, use the 
Reset View tool from the View palette.

Additional viewing tools are available 
on the View palette.

Look At

Equivalent to the ICEM Auto Min Max 
(F2).  If no objects are selected, then 
the whole model fi ts into the view.  If 
any objects are selected, they are 
brought into full view.

Look at also adjusts the speed of 
zooming  to suit the size of the 
geometry, and sets the point of interest 
onto the object.

Point of Interest

The viewing center is called the 
Point-of-Interest.  It defaults to the grid 
origin but can be re-positioned by 
clicking on a piece of geometry during 
viewing (Shift + Alt + Mouse Buttons).

Equivalent to the ICEM Auto Min Max 

Reset View tool from the View palette.
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Moving Frame vs. Pivot Points

In ICEM, you have a moving frame, which is used to specify a from and to location when 
moving objects.  Although you can have many stored planes, only one can be used as the 
moving frame at a time, and it is used globally for any object that needs to be moved or 
rotated.

AliasStudio works differently. Instead of one general 
location, each object (surface or curve) has its own 
individual Pivot Point, which is displayed as a green point 
when the object is selected. This pivot point defi nes the 
starting location used when transforming the object, and 
must be positioned correctly before choosing a transform 
tool.  

The location of the Pivot Point is set using the Set Pivot 
and Center Pivot tools, usually with the snapping tools for accuracy.

When using Transform > Move, the pivot point is the from location, so you need to make 
sure it is in the right location before you move the object. 

With Transform > Rotate the pivot point is the centre of rotation.  The axis and amount of 
rotation is determined by either the choice of mouse button (x,y,z) or by typing in a 
coordinate value to the prompt line.

Place Tool : Moving via Planes

Transform > Object Placement > Place works in a similar way to the 
ICEM moving frame.  You can create two planes, one for the from location 
and one for the to location.  This is useful for complex positioning, but for 
most tasks the pivot point system is easier and quicker to use.

Moving Frames vs. Pivots
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Modeling Tips
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Bezier

ICEMsurf uses Bezier math to construct surface patches and curves. The benefi t of Bezier 
math is that patches are smooth and have no internal continuity breaks – essential for 
Class A quality surfacing.  Bezier is a sub-set of the Non-Uniform Rational B-Spline 
(NURBS) math used by AliasStudio. This means that all the expertise and experience you 
have using Bezier surfaces transfers easily to working with NURBS.

AliasStudio uses NURBS in two ways: single-span and multi-span.

NURBS Single-Span 

Single-span NURBS are exactly equivalent to Bezier Math.  Interaction with the control 
points results in the same surface shape, and smoothness is guaranteed.  The only 
difference for an ICEM user is in the terminology used.

In ICEM, the order of the patch or curve segment determines the number of control points 
available to sculpt the surface shape.  With AliasStudio, NURBS degree is used in the 
same way.  The relationship between the two is : Degree = order - 1

To show the terminology AliasStudio uses, here is an example of a single-span Degree 3 
(order 4) curve and surface.

U=1

U=0

Control Vertex (CV) 
ICEMsurf ‘Control Point’

Hull
ICEMsurf ‘Row’

U-direction CV

Start CV

Curve = ICEMsurf ‘Curve Segment’                      Surface = ICEMsurf ‘Patch’

V-direction CV

Isoparm
ICEM Iso-curve

Surface math
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NURBS Multi-Span

Multi-span surfaces are used mostly for quick 
or concept modeling, where the requirement to 
create the geometry quickly outweighs the 
need for surface quality.

The quality limitations of multi-span curves and 
surfaces are at the segment boundaries between spans, shown by isoparms on a surface 
and edit points on a curve. In these two examples of a degree 3 curve, the fi rst is a 
single-span curve and has edit points only at each end. The curvature plot is smooth.

The second curve has interior edit points. The internal continuity across these edit points is 
G2 (curvature), which is fi ne for general CAD modeling, but may not be good enough for 
Class A surfacing.  The curvature plot clearly shows G3 breaks at the edit point locations.  
The problem is less exaggerated for higher degree curves and surfaces, and more 
noticeable for degree 2 geometry.

Single-span Curve

Edit Point

Multi-span Curve (3 spans)

Explicit Control

Many of the tools in AliasStudio have an 
Explicit Control option, which gives you 
control over the control point layout in a 
surface.  Keeping the spans at 1 ensures that 
Bezier geometry is always created.

(In some tools there is a Bezier option, which 
serves the same purpose.)

Isoparms
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The Control Panel on the right hand side of the AliasStudio screen has most of the tools 
you need to sculpt control points to shape your surfaces.  Some of the Control Panel tools 
always apply to the selected objects, so fi rst use Pick > Object to select your curve or 
surface.

Change Degree (Order)

Select the curve or surface to be modifi ed and type in the required 
degree (order -1)  in the U and V direction.  The change is 
previewed on the screen. Click in the Accept box that appears at 
the bottom right of the screen to confi rm the change.

Displaying Control Points

Use the Control Panel Display section to control the  display of the 
selected objects (use Pick > Object to select the surface(s) or 
curves for display). Deviation controls the display of the scandev 
icon at the bottom of the control panel.

Iso-Curve Sections and Curvature

Display curvature plots along the Iso-curves of a surface.  Use the 
Curvature tool at the bottom of the Control panel to adjust the 
display.  

Shading and Diagnostics

You can apply a simple color, or use the ‘zebra’ 
highlights, curvature or draft analysis of your 
surfaces.  Use the small triangle below the 
shader icons to access the options for each 
shading method.

Cross Section Control

Apply x,y,z , radial or plane based sections, and display a 
curvature plot on each section. Control the curvature sampling and 
scaling using the Curvature icon at the bottom of the Control 
Panel.

Tools

Tools for moving CVs and creating deviation and curvature 
diagnostics.  The following pages describe the Move CV tool in 
detail.

Working with Control Points
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For quick, coarse movements of CVs, you can use the Transform 
palette tools with Pick > Hull and Pick >CV.  For fi ne control and 
accuracy you need the advanced tools available with Move CV.

Move CV has similar functionality to the ICEM Control Point window.

Selecting CVs to Move

The right pop-up Mode menu lets you select single CVs or 
rows (Hull).  When using the Move CV tool, use the Shift key 
to select more than one CV or Hull. 

Alternatively use the Pick > CV or Pick > Hull tool from the 
Pick palette to drag-select many CVs before selecting the 
Move CV tool.

ICEM ‘All’

The ICEM All function is not available in Move CV: instead use the Transform > 
Modify > Proportional Mod tool.

The Falloff value is normally set to 0, 0.5 or 1 and is similar to the ‘law’ in ICEM 
which governs how CVs follow the main CV.  The preceding and succeeding 

settings determine how many CVs follow the main one selected.

Move CV tool



12 Move CV tool   continued

The left pop-up Mode menu covers the functionality of both the XYZ and the 
Tangent, Offset and Normal options in ICEM.

XYZ

When working in a 3D view, the mouse buttons constrain motion in the x, 
y and z directions. (Note: In an orthographic view, the mouse buttons 
switch to a drawing board motion of free/horizontal/vertical.)

The lock options are a secondary tool: use them to prevent a CV 
moving in one direction in case the wrong mouse button is used.

The Step Size setting is used in the same way as Mousewarp and 
Delta in ICEM. Use it to specify the increments using the keyboard 
arrows, and to adjust the infl uence of the mouse movements to make very fi ne 
adjustments.

NUV (ICEM Off set) 

Each CV selected moves along its own normal direction from the surface.  
The NUV function uses the three mouse buttons to move the CVs normal 
to the surface, or in the U or V direction.

Slide (ICEM Tangent)

The slide function moves CVs along hull lines.  Arrows appear on 
the chosen CVs, allowing you to choose which hull line to use as 
the guide.

The arrows on the hull can be used to skew the CVs.

Proj (ICEM Normal)

CVs move in the direction of a 
selected hull or vector.  Use the 
Parallel option to maintain the CV 
offset. 

Use this tool where you would you use the ICEM 
‘Normal’ or the ‘Delta’ Vector tools.

The left pop-up Mode menu covers the functionality of both the XYZ and the 
Tangent, Offset and Normal options in ICEM.
The left pop-up Mode menu covers the functionality of both the XYZ and the The left pop-up Mode menu covers the functionality of both the XYZ and the 
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In the ICEM Control Point window, the Point option opens a Selection window to specify 
around 20 different types of points : end points, corners, edges, etc.

Alias has a simpler approach, where there are only three things you can snap to — grids, 
curves and points — which are specifi ed by holding down a combination of the Ctrl and Alt 
keys when clicking on the desired geometry.

Point Snap (Ctrl) :

In AliasStudio, a point refers to one of the recognized control points, and they must be 
made visible using the Display section of the Control Panel.

CV       Edit Point Key Point Blend Point

Curve Snap & General Points (Ctrl + Alt) 

The curve snap attaches to any curve, line, arc, surface edge, iso-curve or face edge. 

Corners can be found by clicking on an edge, holding down the mouse 
button and dragging the cursor until it reaches the blue cross, which 
turns yellow to indicate  that it has been accurately snapped to.

Mid-Points and sub-divisions can be found by changing the settings in 
the Curve Snap Options, next to the snapping icons (top right). 

Grid Snap (Alt)

Mostly used to snap control points onto the center line grids.

In the ICEM Control Point window, the Point option opens a Selection window to specify 

Snapping to points



14 Surface Evaluation

Cross Sections and Curvature

The pre-set x, y and z sections can be applied to selected 
geometry, and modifi ed by double-clicking to open the option 
window. Click on the curvature icon to display a curvature plot 
along the sections, which automatically update as you model.

Use New to create additional section ranges, and Clear to control 
the display of the sections.

Refl ection Lines (Iso-Angle)

A more accurate evaluation than the zebra stripe 
shading is provided by the Iso-Angle tool.  This 
shows you the line of zero angle between the 
surface normals and an infi nite ‘light source 
direction’. 

This is found on the Evaluation Palette where you 
will fi nd additional advanced tools.  Double-click to 
open the option window to set up the display.
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Controls on/off 

Turning on the display of control points is 
something you will do hundreds of times a 
day, and so it is particularly useful to set up a 
hot key.

To set this up, use Preferences > Interface > 
Hotkeys/menus.

Near the bottom of the option window, there is 
a Special... Display Functions section. This 
lists settings available in the Object Display > 
Control window.

Most experienced users set up the two options 
illustrated (you can choose any hot key you 
like, F3 and F4 are just examples).

Alternatively, set up the marking 
menus with the Object Display 
> Control settings.

Pick Walk

If you have one CV selected, or one Hull, the pick walk lets you step 
along to the next CV or Hull without leaving the tool you are using.  
Hold down the Ctrl key and use the keyboard arrow keys.
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Faces, Trims, & 
  Curves-on-Surface

Cutting Surfaces

Curves-on-Surface

Projecting & Intersecting

Faces and Trims

Workflows



18 Cutting surfaces

The ways ICEMsurf and AliasStudio cut surfaces have two significant differences.  First, 
the terminology used is different and potentially confusing.  Second, AliasStudio has the 
concept of a Curve-on-Surface, which has no equivalent in ICEMsurf. 

Terminology

In AliasStudio, the functions availably for modifying surface boundaries are the same as in 
ICEMsurf, but the terminology is different:

Trim

ICEMsurf: Face

Trim Convert

ICEMsurf: Trim

Curve-on-Surface

A Curve-on-Surface is different from a normal NURBS or Bezier curve used for modeling 
and is a fundamental part of the trimming workflow in AliasStudio.  A regular curve is 
defined in the x,y,z modeling space, and is free to move in any direction.  A CoS is defined 
in the UV parameter space of the surface it lies on, and cannot move away from that 
surface.  A CoS also has only Edit Points, no CVs.

In AliasStudio, the only way to trim (face) a surface is to have a Curve-on-Surface  (CoS) 
defining the boundaries of the trim regions. Curves-on-Surface are also important in 
surfacing operations on the edges of trimmed surfaces. They provide better anchoring of 
CVs and blend points when attaching to the edges of trimmed surfaces. 

A curve is projected 
onto a surface...

A Curve-on-Surface is 
created... (in ICEMsurf this 
would be a Bezier curve)

...which is used to 
trim the surface.

Detach

ICEMsurf: Trim to 
Iso-curve



19Curves on Surface

CoS and Construction History

The defi nition of the CoS is with respect to the 
surface it lies on; hence the two are linked 
completely. Any change to the surface will 
therefore be automatically refl ected in a change to 
the CoS. 

There is also a Construction History relationship 
between a projecting curve and the resultant CoS.  
Any changes to the projecting curve will 
automatically update  the CoS.  Similarly, a CoS at 
the intersection between two surfaces will update 
if the surfaces are modifi ed. (A CoS with history is 
displayed in green; one that no longer has history, 
in blue).

These two characteristics, combined with the use of real-time diagnostics, make working 
with CoS very interactive and effi cient. 

Working with Curves-on-Surface

A curve-on-surface has its own selection tool, Pick > 
Object Type > Curve on Surface.  Use this to select 
and delete CoS that are no longer required. (A surface 
with a CoS on it is displayed with dotted edges.)

If a CoS or a trimmed edge is converted to a normal curve 
(using Curve Edit > Create > Duplicate Curve), it typically has 
many spans.  You can rebuild it to Bezier (single-span) using 
the control panel, and then check it using the deviation tools 
on the Locators palette.

The traditional workfl ow in AliasStudio has two steps: creating 
the CoS and then trimming the surface.  The following pages 
describe the Surface Edit palette tools used for each step.



20 Step 1: Creating Curves on Surface (CoS)

Projecting a Curve along a Surface Normal

This method works best when the curve is close to the surface.  To use it accurately, you 
should adjust the tolerance values in the option window.

Tolerance 
The smaller the value, the more accurate the projection, but 
the longer the calculation time required. 

Curve data factor 
The default is 1, which is suffi cient for most surfaces. Larger 
values increase calculation time. (Only increase the value for 
very simple surfaces.)

Projecting a Curve along a Vector

Any curve, (edge or isoparm) can be projected onto a surface to 
create a CoS.  There are two ways to select the direction of 
projection:

Using a vector — First create a vector using Construction > Vector, 
then select the vector when prompted by the Project tool.

Using the current view direction — typically you use an 
orthographic view (with perspective turned off) to get an accurate projection and 
predictable result.

Surface-Surface Intersection

The Intersect tool calculates the intersection line 
between the selected surfaces, and creates a 
CoS on each surface. This can be used to trim 
the surfaces to the intersection.

The Locators > Curve Curvature tool can be 
used  on the CoS to analyze the surface-surface 
intersection (SSI).  It dynamically updates as the 
surfaces are modifi ed.

Projecting a Curve along a Surface Normal

This method works best when the curve is close to the surface.  To use it accurately, you 
should adjust the tolerance values in the option window.

Any curve, (edge or isoparm) can be projected onto a surface to 

values increase calculation time. (Only increase the value for 

Projecting a Curve along a Vector

Any curve, (edge or isoparm) can be projected onto a surface to 
create a CoS.  There are two ways to select the direction of 
projection:

Surface-Surface Intersection

The 
between the selected surfaces, and creates a 
CoS on each surface. This can be used to trim 

The 
used  on the CoS to analyze the surface-surface 
intersection (SSI).  It dynamically updates as the 
surfaces are modifi ed.



21Step 2: creating faces and trims

Trim (ICEMsurf: Face)

The trim tool only works on surfaces 
that have one or more CoS. You are 
prompted to select the surface twice: 
fi rst to choose the surface, and then to 
select the region(s) of the surface you 
want to keep.

There are no tolerances displayed during 
the trim operation; instead, the tool uses 
the settings in the Trim section of 
Preferences > Construction Tolerances. 
You will typically tighten these tolerances 
as shown. Tolerances are described in more detail in the next chapter.

Open the UnTrim option window to choose 
untrimming step-by-step for multiple trims, or all trims 
at once. Don’t forget to pick and delete the old 
curve-on-surface if you no longer need it.

Trim Convert (ICEMsurf: Trim)

In AliasStudio you fi rst need to Trim the surface, and only 
then can you use the Trim Convert tool to re-build the 
surface with a natural edge.

The trim tool only works on surfaces 
that have one or more CoS. You are 
prompted to select the surface 
fi rst to choose the surface, and then to 
select the region(s) of the surface you 

as shown. Tolerances are described in more detail in the next chapter.

Open the 
untrimming step-by-step for multiple trims, or all trims 
at once. Don’t forget to pick and delete the old 
curve-on-surface if you no longer need it.
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Trimming without Projecting First

To avoid the two-stage process, the 3D Trimming option in the Trim tool allows a workfl ow 
similar to that used in ICEM. The option allows you to select the surface, the curve and the 
region to keep in one operation.

Its success depends on choosing the correct view 
(to determine the projection direction) or using the 
Project Normal option.

Trim to an Iso-Curve

Splitting a surface at an isoparm doesn’t require the use of CoS. Extra 
isoparms (iso-curves) can be shown using the Object Edit > Patch 
Precision tool. Use Object Edit > Detach and click on an isoparm in the 
direction you want to split the curve.  Use the Alt and Ctrl keys to snap 
exactly on isoparms and mid-points.

Ctrl: Snap to isoparms Alt: Snap to 0.5 
parameter (mid-
point)

Ctrl + Alt: Snap to 
adjacent surfaces

Creating Curves instead of CoS

The Project tool has the option of creating a 
standard curve instead of a curve-on-surface. 
Setting Match Original to on creates the 
projected curve with the same number of CVs as 
the curve being projected.

With Match Original off, the curve is more 
accurate, but has more spans.

Workfl ows
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Align

Modeling Tolerances

Construction History

Measuring Continuity

Matching surfaces
  G0, G1, G2
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The equivalent of the ICEM Match 
tool is Object Edit > Align.  This 
tool creates a G0, G1 or G2 
relationship between two surfaces 
(or two curves) and maintains that 
relationship as CVs are moved.

Alignment Type : Edge

Open the Align option window to choose the 
continuity level, skewed or aligned edges, 
and options for part alignment and blending 
extra CV rows.  

Using the Edge option when aligning natural 
surface edges allows free movement of the 
CVs.

Follow the prompts to fi rst select the edge of 
the surface to be modifi ed and then the 
reference edge to be matched to.

Manipulator arrows appear on the Hulls. Use 
these to interactively adjust the CVs while 
maintaining continuity.

Exact Slider

In this example, G2 (curvature) continuity has 
been specifi ed.

If Exact = 0, there is minimal movement of 
the CVs.

If Exact = 1, the G0 CVs are exactly matched 
to the CV locations on the master surface, 
and the G1 and G2 CVs adapt to match the 
length ratio of the master surface  tangents.  

The equivalent of the ICEM Match 
tool is 
tool creates a G0, G1 or G2 
relationship between two surfaces 
(or two curves) and maintains that 

1. Select input 
(connection edge)

2. Select Master 
(reference edge)

Adjust with arrows.

Exact = 0 Exact = 1

Align
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When matching surface edges the CVs on both 
surfaces naturally align.  However, when matching 
to the interior of a surface, or to a trimmed edge, 
the CV layout may be mismatched, and so a 
different method is required.  The Vector and 
Project options provide vector-based control over 
the alignment direction of CVs.

Vector Options

A vector can be specifi ed as being in the X,Y, Z 
axis directions, in the view direction, or the surface 
normal direction.

Alternatively, you can create a vector entity using 
the Construction palette, and rename it using 
Windows > Object Lister.  The vector can then be 
selected using the Picked Vector option.

Alignment Type : Project

The Project option allows you to align a natural edge to the interior of a surface.  How the 
CVs are moved is specifi ed by the vector you select.  A curve-on-surface is created on the 
master surface along the aligned edge.

In this example, the CVs on the wheel arch surface have moved in the Y direction, to meet 
and align with the surface.

Alignment Type : Vector 

This option only applies when aligning surface edges. It allows the tangent and curvature 
CV rows to move along one direction only (specifi ed by a vector). The Align tool attempts 
the best alignment given this constraint.
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It is essential to know how accurately the two surfaces have been matched, and to control 
the level of accuracy so that it is appropriate to the design phase.

AliasStudio Construction Tolerances

AliasStudio differs from ICEM in that it has one master set of tolerances that it uses for all 
tools. These are set using Preferences > Construction Options, which opens the 
construction options window:

Construction Presets

The construction Presets are useful as a 
starting point, but for Class A surfacing you 
typically want to defi ne your own tolerances.

Choose one (CATIA V5 is a good choice) 
and click Copy to create your own, 
customizable set.  You can rename the set, 
and have as many different sets as you 
need.

Units

The modeling units should default to mm; 
use this section to check or modify the units.

Tolerances: Fitting

Checkpoints are how many times an edge is 
checked for tolerance.  Increasing this value 
increases the accuracy of checking, but can 
slow down the system.

Tolerances: Continuity

The three settings are for G0, G1 and G2 
continuity measurements.

Curvature is measured as 

Curvature Deviation = (Radius1-Radius2)/
Radius1 + Radius2) 

Construction Presets

The construction Presets are useful as a 
starting point, but for Class A surfacing you 
typically want to defi ne your own tolerances.

Choose one (CATIA V5 is a good choice) 
and click 
customizable set.  You can rename the set, 
and have as many different sets as you 
need.

Units

The modeling units should default to mm; 
use this section to check or modify the units.

Tolerances: Fitting

Checkpoints
checked for tolerance.  Increasing this value 
increases the accuracy of checking, but can 
slow down the system.

Tolerances: Continuity

The three settings are for G0, G1 and G2 
continuity measurements.

Curvature is measured as 

Curvature Deviation = (Radius1-Radius2)/
Radius1 + Radius2) 

construction options window:

The Presets help to 
ensure successful 
data transfer into 
downstream CAD 
systems.

Modeling tolerances
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Tolerances Workfl ow

You must select your tolerance settings in the 
Construction Options window before you start to 
model.  

AliasStudio will then use these values as a goal to 
align two surfaces.  If it can’t achieve the required 
tolerance with the number of CVs available, it may 
increase the degree or the number of spans.

Explicit Control

To avoid this and maintain Bezier (single-span) 
geometry, you can use the Explicit Control option 
to specify the number of CVs. 

If you cannot achieve the tolerance you need, then 
it is your choice to increase the degree, or re-
design your control point layouts to solve the 
problem.

Tolerance Display

If the Continuity Check option in the Align tool is 
selected, the tolerances are shown on the 
geometry at the aligned edge.

Yellow (selected) or red (unselected) indicates that 
the continuity achieved is not within the tolerances 
set in the Construction Options, and the values are 
displayed.

Green indicates that the continuity is achieved, but  
the tolerance values are no longer displayed. If you 
prefer to always see the tolerances, set very high 
tolerance values in the Construction Options 
window, and use your own judgement to assess 
whether they are successful.

An extra span has 
been added to 
achieve tolerance.
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Construction history is the saved information about how 
an object or an action was created.  When you edit the 
construction history the object or action will automatically 
update.  

A curve or surface with Construction History is displayed 
in dark green wireframe color, indicating that the history 
can be re-activated at any time.

With the Align tool, the Construction History works in two ways:

Master/Input CV Alignment

When CVs are selected and moved on the master 
surface, CVs on the input surface automatically 
update to maintain continuity.

When CVs are selected and moved on the input 
surface, they can only be moved to legal positions, 
where the continuity will be maintained.  CVs moved 
to illegal positions will jump back to a correct 
position when you release the mouse button.

To delete the construction history use Delete > 
Construction History.  The surface reverts to dark 
blue and the CVs can be moved independently.

Re-Activating the Option Window

The option window can be re-opened at any time and the options 
modifi ed, for example, to change the Continuity from Tangent to 
Curvature. Use the Object Edit > Query Edit tool, click on the 
secondary surface with the left mouse button and the option window re-opens.  Changes 
made now affect the secondary surface.

To update the surface, choose the Auto Recalc option, or click on the Recalc button at the 
bottom of  the option window.

To undo an alignment, click on the Revert 
button at the bottom of the  Align Options 
window

Construction history
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The tolerance display used by the Align tool is a subset of the functionality of the 
Surface Continuity tool found on the Evaluate Palette. All of the functions and 
workfl ows described here equally apply to the embedded continuity check in the 
Align tool.

Surface Continuity Locator

The Surface Continuity tool checks the boundary between two surfaces and 
creates a Locator to display the G0, G1 and G2 accuracy.  A Locator  is a special 
entity used to check and display information, and it has its own Pick and Delete 
tools.  (Other locators can be found on the Locators palette.)

There are three ways to select the display options for Surface Continuity:

1.  Double-click on the icon to open the option window before selecting the edge.

2.  Use Windows > Information > Information Window to display and modify the settings 
after selecting the edge, when the locator is selected.

3.  Use the mouse buttons to interactively adjust the settings as described in the prompt 
line, shown below:

Click on the join between two 
surface patches. The locator is 
shown.

A single click with the middle 
mouse button shows the comb; 
clicking and dragging adjusts the 
sampling.

For detailed information at a 
particular location, use the right 
mouse button.

Use Delete > Locators to remove 
the locator.

Measuring continuity
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New Curve by Edit Points

The New Curve by Edit Points tool is the most common way to start a curve.  Simply click 
a start and end point on the screen to create a single-span (Bezier) curve. 

To create a symmetrical curve for example, 
use Grid Snap to place the ends equally 
across the centre-line. Open the option 
window to select the degree (order) of the 
curve.

There is no functionality in AliasStudio to force the 
CVs to be symmetrical. You need to maintain 
symmetry by using Pick > CV and the mouse 
constraints carefully.

Modify the Degree in the Control Panel to change 
the number of CVs.  Keep Spans set to 1 for a 
Bezier curve.

Displaying Curvature

Use the Locators > Curve Curvature tool to 
display a comb on the curve to evaluate it as 
you move CVs.

Follow the prompts to select the 
curve and use the mouse buttons to 
adjust the display.

Use Windows > Information 
Window to modify the curvature 
display. 

Use Delete > Delete All Locators to remove the display.
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The Object Edit > Align tool can be used to 
blend any curve into a surface (or another 
curve).  If the curve isn’t aligned to an edge or 
an isoparm, project a curve-on-surface to use 
as a reference to align to. Alternatively you can 
use Blend Curves, which offer automatic 
alignment and Associativity.

Blend Curve Toolbox

Blend Curves attach to surfaces and automatically align with G2 
continuity.  The curves are normal NURBS curves, typically 
single-span degree 5, but are manipulated using Blend Points, 
not CVs.  Blend Curves have construction history, and maintain 
their connection to the surface while the surface is modifi ed.

Pick > Blend Point Blend Point Manipulator

Blend Curve Tips

See the chapter on Creating and Fitting Curves in the Technical Surfacing PDF for a full 
explanation of Blend Curves.

By default, CVs aren’t displayed on a Blend Curve.  Use Object Display > Control to 
change the default so that CVs are always displayed, or just use the Control Panel to 
display and monitor CV positions.

Use the Auto Align at Surface Corners option in the Crv create option box to get good 
default alignment results

Because Blend Curves are associated with the 
surface, you need to specify which surface to attach 
them to. If you select a joint edge, the standard pick 
chooser appears, with a ‘black fi nger’ icon.  You need 
to keep the mouse button pressed down, and drag the 
cursor to the black fi nger until it highlights.  Keep 
holding the mouse button down and then drag along 
the edge to your chosen location.  

Pick > Blend Point



34 Accurate Arcs

Keypoint Curves

Keypoint Curves are CAD-like drafting curves, creating accurate 
geometric shapes — in particular, exact arcs and circles. First 
create the curve in the modeling window. Then, with the curve 
selected, use Windows > Information > Information Window to type 
in the dimensions required.

To interactively modify keypoint 
curves, use the Drag Keypoints 
tool in the Keypoint curve toolbox.

Rational Flags

This is an option set in the Preferences > Construction Options window and applies to all 
surfaces of revolution, and to the Circle Primitive (see below).

Non-Rational geometry gives each CV an equal weighting of 1. 
This is the preferred option for modeling, but it has the 
disadvantage of not creating exact circles and arcs.

Rational geometry allows different weighting on CVs, which is 
used to create an exact arc.

Curves > Primitives > Circle

With the circle tool, the result you get depends on your 
choice of Rational Flag, but also on your choice of Periodic 
geometry set in the Circle tool option window.

Rational Non-Rational, 
Periodic

Non-Rational,  
Non-Periodic

To interactively modify keypoint 
curves, use the Drag Keypoints 
tool in the Keypoint curve toolbox.

To interactively modify keypoint 
curves, use the Drag Keypoints 
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Curves Palette
Create Curve by CVs has a Progressive Degree 
option that automatically increases the degree of 
the curve as you place CV points, up to the value 
set in the option box.

Curve Edit Palette 

Use Duplicate Curve to create a 
curve from an isoparm, surface 
edge, trim edge or curve-on-
surface.

Curve Planarize fl attens a curve 
onto a construction plane, or to the 
closest fi t.

The Curve Fillet tool creates the 
arc curve and trims back the two 
curves.  The radius can be 
modifi ed using the Information 
Window.

Object Edit Palette

The Symmetry Align tool forces a 
curve or surface to stay tangent 
across a center-line. It works in 
conjunction with Layers – see the 
last chapter.

The Extend tool extrapolates a 
curve or surface to grow or shrink 
it without changing the shape.

Set the Max Spans Factor to zero 
to match the CV layout in the 
offset curve or surface

Use Curve Rebuild (Uniform 
Knots option) if you have many 
curves to rebuild.  (It’s quicker than 
doing them one-by-one using the 
Control Panel.)

Curve Section is used to trim 
curves.

Fit Curve uses two algorithms 
(Hull Fit and Least Squares) to 
match a curve to raw data.

Curve Stretch provides 
manipulators to modify the curve 
while maintaining the CV layout.

Surface Edit Palette

   Use Surface Rebuild (Uniform 
Knots option)  if you have many 
surfaces to rebuild at once. 

Tools for unifying and 
fl ipping surface normals.

Create Curve by CVs
option that automatically increases the degree of 
the curve as you place CV points, up to the value 
set in the option box.

Use 
curve from an isoparm, surface 
edge, trim edge or curve-on-
surface.

Curve Planarize
onto a construction plane, or to the 
closest fi t.

The 
arc curve and trims back the two 
curves.  The radius can be 
modifi ed using the Information 
Window.

The 
curve or surface to stay tangent 
across a center-line. It works in 
conjunction with Layers – see the 
last chapter.

The 
curve or surface to 
it without changing the shape.

Set the 
to match the CV layout in the 
offset curve or surface

Set the 

Use 
Knots option) if you have many 
curves to rebuild.  (It’s quicker than 
doing them one-by-one using the 
Control Panel.)

Curve Section
curves.

Fit Curve
(Hull Fit and Least Squares) to 
match a curve to raw data.

Curve StretchCurve Stretch
manipulators to modify the curve 
while maintaining the CV layout.

Curve Stretch

Tools for unifying and 
fl ipping surface normals.
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AliasStudio doesn’t distinguish between Patch and Surface tools, 
even though some tools are limited to creating only a single patch 
(square, rail, skin) and others will create multiple surfaces if they 
are built from multiple curves or edges.  

The icon colors indicate the function of the tool: Blue icons are the 
primary surfacing tools for creating the slab surfaces of the design.  
Green represents a Transition or Detailing surface tool.

Surface from 4 Points

A quick way to get a starting surface is to use a 
primitive Plane to create a degree 3 (order 4) 
patch.

The only tool that creates a surface from corner 
points is Square.  You need to specify four 
points, and these can be placed freely on a work 
plane, curve snapped (Ctrl + Alt) to raw or scan 
data, or snapped to existing geometry.

The Surface Edit > Fit Scan tool tries to match 
the square patch to scan lines.

The Point Cloud palette has tools for creating 
surfaces on raw data.

Surface from Curves

   The Skin tool creates a simple straight-line 
surface between two chosen curves, or a 
multi-span smooth surface through multiple 
curves (use the Shift key to select more than 2 
curves)

The Square tool requires four curves, and they 
must be coincident (touching) at the corners.

Square: 4 points

Skin : 3 curves

Skin : 2 curves

A quick way to get a starting surface is to use a 
primitive 
patch.

The only tool that creates a surface from corner The only tool that creates a surface from corner 
points is 
points, and these can be placed freely on a work 
plane, curve snapped (Ctrl + Alt) to raw or scan 
data, or snapped to existing geometry.

The only tool that creates a surface from corner 

data, or snapped to existing geometry.

The Surface Edit > 
the square patch to scan lines.

The The 
surfaces on raw data.
The 

curves (use the Shift key to select more than 2 
curves)curves)

The 
must be coincident (touching) at the corners.

Square: 
4 curves
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Flange Surfaces

The Multi-Surface Draft tool creates a 
fl ange surface along an edge, or a chain 
of edges. Use Explicit Control or the 
Bezier option to control the surface 
quality.

The Draft/Flange tool provides a similar 
function, from curves or surface edges.  It 
can create surfaces on both sides of the 
curve, either as a pair, or as a single 
surface.

Profi le Surfaces

As a monorail (with 1 rail curve and 1 
generation curve) the two curves don’t 
need to be touching. 

In Birail mode (2 rails and 1 or many 
generation curves) the curves must be 
touching at the corners.  The inputs can 
only be single curves, edges or iso-
curves, and the tool can only create a 
single surface patch.

Surfaces of Revolution

The Revolve tool creates a surface of 
revolution from one or more curves.  The 
center of the revolve is either the global 
x,y,z axes, or the object’s local pivot point.

Standard 
revolved 
shapes can 
be found on 
the Surfaces 
> Primitives 

menu.  They are multi-span surfaces, and the cone 
and cylinder are grouped surfaces.

The 
fl ange surface along an edge, or a chain 
of edges. Use 
Bezier
quality.

The 
function, from curves or surface edges.  It 
can create surfaces on both sides of the 
curve, either as a pair, or as a single 

As a 
generation curve) the two curves don’t 
need to be touching. 

In In 
generation curves) the curves must be 
touching at the corners.  The inputs can 
only be single curves, edges or iso-
curves, and the tool can only create a 

The 
revolution from one or more curves.  The 
center of the revolve is either the global 
x,y,z axes, or the object’s local pivot point.

revolved 
shapes can 
be found on 
the Surfaces 
> 

monorail

birail
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The blending surface tools are designed to work with Construction History.  The blend 
surfaces update as you sculpt the slab surfaces, allowing a quick exploration of forms, 
while giving a fi nished appearance useful for design review.

Using the default settings, the tools may create multi-span surfaces not suitable for Class A 
modeling.  However, the option window provides Explicit Control, which you can use to 
control the surface quality.

Freeform Blend

Freeform blend creates a surface that bridges 
the gap between two other surfaces (or groups 
of surfaces), and matches continuity at the 
edges. The chain select option lets you select 
multiple edges with one click.

In its default mode, it typically creates heavily 
parameterized surfaces, but if you work with 
the Explicit Control options you can get good 
results for concept modeling.

Use the Flow Control options to defi ne the end 
conditions.

Profi le Blend

The Profi le Blend tool uses additional profi le 
curves to further control the character of the 
blend surface.

Ball Corner

The Ball Corner tool is designed for the 
iterative stages of a design, when you may 
need to fi nish off a model quickly for a 
presentation. 
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Surface Fillet

The tool will build a fi llet surface, and then cut back (Face) the slab surfaces in one 
operation. It is not necessary to fi nd the theoretical intersection of the slab surfaces before 
using the Surface Fillet tool (though you may choose to do so for quality purposes). 

Construction history means that you can build the fi llet surface and then modify any of the 
settings in the option window, and the fi llet surface will update (hit the Recalc button or set 
Auto-Recalc in the options)

Quality & Profi le Options

The Construction Type and Section 
Type options provide the full range of 
fi llet profi les.

Use the Flow Control options with 
Explicit Control and Bezier settings 
to adjust the CV layout.

Tip: With Variable radius, use the 
Shift key to add or remove additional 
radius values by clicking on the orange edge. Use the middle mouse button to move the 
radius values along the edge. 

Overlap = OK

Not meeting = OK 
(if the fi llet is big 
enough to cross 
the gap)

Click on blue 
arrows to select 
which side to 
build the fi llet
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Continuity

The Rail and Square tools have the option to specify a continuity 
relationship with the surface edges they are built from.

The Position, Tangent and Curvature are standard G0, G1 and 
G2 relationships.  The other continuity options are explained 
below :

Tangent Angle

Implied Tangent / Curvature

Use on the center-line edge of a 
symmetrical half to ensure tangency 
between the mirrored surfaces.  Implied 
Tangent gives better results than Implied 
Curvature.

Square: Fixed Boundary / Free Boundary (G0)

The Fixed option holds continuity strongly.  Free (and Position in 
the Rail tool) are more relaxed, and let continuity fail on this edge 
if it helps to create better results on other edges.

Position: angle 
may vary

Tangent Angle: 
consistent angle

Square: Fixed Boundary / Free Boundary (G0)



41Advanced Blending     continued

Rebuild

The Rebuild ‘ticks’ can help to improve the 
parameterization of edges, particularly when building 
from trimmed edges, or when opposite edges have 
different parameterization. Use with Explicit Control to 
get the best CV layout.

Curve Segments

Only available with one generation curve, the Curve 
Segments option gives you interactive control over how much of each rail curve is used to 
create the surface.

Colinear Options

Select the colinear option to align the CV 
directions of the surfaces, at each edge.  

Be careful not to select these options when 
building to a trimmed edge, as the CV layout 
may be in a different orientation.

Segments option gives you interactive control over how much of each rail curve is used to 

Colinear Options
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44 Layers/Lists

Layers are the primary method of managing the geometry in your 
fi le.  You create and name layers to suit the project you are 
working on, and then assign your geometry to the layers.

After the model is organized this way, you can use each layer to 
control the visibility, the symmetry display, the color and the 
selection state of the geometry assigned to it.

Layer Bar

The Layers menu is used to create, delete and manage layers, 
which are displayed in the Layer Bar at the top of the screen, just 
below the menus.

The fi rst layer in the list is always the Default Layer, and it cannot be deleted.  If there are 
no new layers, all geometry is placed on the Default layer. 

Click a layer tab to make it the active layer. It is shown in yellow, and any new geometry is 
automatically placed onto it. Or simply assign geometry to the correct layers as required. 
To re-arrange the layers on the layer bar, use the middle mouse button to drag the layer 
tabs left or right. To scroll, use the arrows at the right end of the bar.

Layer Tab Menu

Each Layer tab has a sub-menu for assigning objects and turning the layer visibility on and 
off. The Set State sub-menu puts geometry into the background, visible but not pickable:

Pickable:  normal working state.

Reference: geometry can be snapped to, but not selected.  

Inactive:  not selectable

The fi rst layer in the list is always the Default Layer, and it cannot be deleted.  If there are 

Click to set the 
layer color.
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Layer Symmetry

To view a mirror-image of the geometry on a layer  (shown with dotted lines), use 
Symmetry on the layer tab.  The mirror direction defaults to car-line; to change it, use 
Layer > Symmetry > Set Plane . 

1st CV on center-line

2nd CV tangent

If symmetry is set up for a layer then Object Edit > Symmetry Plane Align can be used to 
ensure tangency along the center-line 
edge of the geometry.

Object Lister

An alternative to using the Layer bar is 
to use Windows > Object Lister.  The 
default setting is Show by Layers, and 
each layer is listed with its submenu 
accessed using the right mouse button.

If you prefer this style of working, you 
can turn off the layer bar using Layers > 
Toggle Layer Bar.

Layers versus ICEM Lists

Layers work slightly differently than Lists 
in ICEM, but they serve the same 
purpose. 

There is no direct equivalent to the List DB.  One item cannot be in two layers at the same 
time.  So, if an object was in the Default Layer for example, it will be no longer be there 
when you assign it to another layer.

1st CV on center-line

2nd CV tangent
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The functionality of the ICEM Object Editor is provided by two tools in AliasStudio: the 
Object Lister and the Information Window. The Object Lister is used here to explain how 
AliasStudio organizes the geometry in a fi le.

Atoms

There is no equivalent to the atom (patch/curve segment) and 
molecule (surface/curve) distinction used in ICEM.  The smallest 
entities are simply called curves and surfaces, and these terms 
apply equally to single or multi-span geometry.

Molecules & Parts

Curves or surfaces can be grouped together to form a new node, 
which can be given a name, and selected as one object.  This can 
be used in the same way that you group curve segments into 
curves in ICEM. The main difference is that a group can contain a 
mix of different entities.

Like ICEM, AliasStudio doesn’t create assemblies, instead, the 
Edit > Group tool can be used to simulate a structure of parts.

To select entities within a group, use 
Pick > Component, or Edit > Ungroup 
to return to independent entities.

Hierarchical Grouping

In this example of a mannikin model, 
each limb needs to be rotated to pose 
the model.  For example, the lower leg 
surfaces need to behave like a single 
object, and be able to rotate around 
the knee.  Grouping provides a single 
pivot point that allows all the surfaces 
in the lower leg to rotate as a single 
entity.

Here, groups have been made and 
carefully named, and then grouped 
again to form a complex hierarchy 
simulating the motion of the body.  A 
simple example would be a car door.
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When modeling, it can be useful to quickly turn some geometry on or off, or put it into a 
background mode, without fi rst organizing it onto layers.  The Object Display window 
provides tools to temporarily control the display of objects.

Control  ❑

Mostly replaced by the 
Display section of the Control 
Panel, it is still useful for 
setting default preferences for 
the display of controls.

It is also the only place to 
control the display of 
Keypoints.

Invisible / Visible

This tool is used to make 
selected objects invisible.  
The Visible tool make all 
objects visible again. To 
control visibility per object, 
you can use the right 
mouse button in the 
Object Lister.

Hide Unselected

Allows you to select the object 
you want to view, and make 
all the others invisible.  Use 
Object Display > Visible to 
return the object to the view, 
or use Utilities > Plug-in 
Manager to load the plug-in 
toggleObjectInvisibility

Template

Use with Pick > Object and 
Pick > Template to toggle 
geometry to and from a frozen 
(gray) state.

Other Useful Display Tools

Show menu on each window (shown 
right)

Control Panel > Transparency and 
Quality sections

Object Display > Draw Style :  style of 
CV display:

Preferences > Interface > User Colors 
to modify the colors used for CVs, 
screen background etc.

Hide Unselected



48 Saving Data

When you fi rst use AliasStudio, a user_data 
directory is created.  This is the recommended 
location for storing your data, using the project 
structure described below.

Note: you can use the browser window to store 
your data at a different location on your 
computer or network if required.

user_data

This is equivalent 
to the D:\
DATABASE\SURF 
location in ICEMsurf.  By default it contains the demo 
project, provided as a ‘get started’ working area, and the 
dumpster . This is rarely used – it manages the deletion of 
fi les through an old browser interface.

Project Folders

A project is simply a directory with sub-directories containing 
different data types. In the File Browser (accessed when you 
use File > Open or File > Save As), you can use the Project 
menu to create and manage project directories.

New Project creates a directory called new_project  
containing all the data sub-directories.  Rename the 
directory for the job you are working on (e.g. Wheel _X923).

Set Current sets the selected project as the default save 
location, so that all related data for a project is stored in one 
place, including crash fi les.

Data Directories

Just like the eight directories in the ICEM Project Overview, 
AliasStudio stores different types of data in different 
sub-folders. The key folders are wire and reference, where 
geometry is stored, and pix for images.

Some of the folders created will never be fi lled – they relate 
to animation and rendering data (you can delete them).

location in ICEMsurf.  By default it contains the demo 
project, provided as a ‘get started’ working area, and the 

P
ro

je
ct

 F
ol

de
rs

D
at

a 
D

ire
ct

or
ie

s



49Saving Data     continued

The AliasStudio geometry is in a format called wire, with a .wire fi le extension. This format 
can be used by AliasStudio to import other AliasStudio data only.  For all other CAD 
systems you need to translate the data into one of the standard fi le formats.

Data Transfer

The IGES fi le format is the most universally used data format, and is 
best for translating data to and from ICEM.  To export from 
AliasStudio, select the objects you want to transfer, use File > Export 
> Active As... to open the option window and select the IGES fi le 
format.  

To import to AliasStudio, use File > Open or File > Import.

Unlike ICEM, there is no special sub-directory for IGES fi les; by 
default they are stored in the wire directory.  It is a good idea, 
however, to create a new sub-folder to store and manage your IGES 
fi les.

As well as using industry standard formats such as IGES and STEP, 
some direct translation formats for common CAD systems are 
provided as purchasable options.  For example, the CATV5 
DirectConnect is a stand-alone utility that allows the exchange of 3D 
model data between AliasStudio and CATIA. 

For more technical detail on data transfer, refer to the on-line help 
‘How To’ section, or the Data Transfer PDF. 

Reference Manager

File > Reference Manager does a similar job to the ICEM version. It can import large 
amounts of engineering data while maintaining interactive performance.  It also can import 
large amounts of design data and provide alternative shading and comparisons for design 
reviews.

An AliasStudio .wire fi le is translated into a .wref format (similar to  the EDF format in 
ICEM) and stored in the reference sub-directory in the project folder.

Auto Save

By default AliasStudio won’t automatically save your data, so it is very important that you 
save your work regularly.  You can choose to turn on an Autosave function using File > 
Checkpoints, but this shouldn’t be used as a substitute for regular saving.



50 What Next?

This brief guide has given you the key information to start using AliasStudio for technical 
surfacing tasks.  We encourage you to use the on-line help and the PDF reference 
manuals to expand your knowledge as you gain hands-on experience with the software.

AliasStudio functionality covers a wide range of the design and development process. Your 
surfacing skills will give you an excellent starting point for working on fast concept 
development, or modeling in different industries, such as automotive, marine, product or 
packaging design.

Presentation and real-time viewing of designs has become a fundamental part of the 
design process.  Exploring Hardware Shading in AliasStudio will add another dimension to 
your professional skills and provide great job satisfaction when you see your work 
presented at the highest quality.  If you work in a large organization, you may want to look 
at the functionality of Autodesk’s Showcase product which integrates with AliasStudio to 
provide full design review support.

We hope this booklet helps you overcome the inevitable frustrations of learning a new 
software package, and that you go on to enjoy developing your technical and creative 
expertise with AliasStudio.

For information on Training Courses please go to www.autodesk.com and choose 
Services & Support > Product Training.
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3D View Mouse Constraints 2D View Mouse Constraints

Viewing Marking 
Menus

Pick Walk UV Snapping (1.0) UV Snapping (0.5)

Point Snap Grid Snap Curve Snap


